[JDEV] Jabber and Flash

Keith Willis kwillis at cyberlearninglabs.com
Mon Feb 2 21:20:23 CST 2004

Ok, The last email was a bit off.  I thought I was replacing the "/>" with
"> " but I forgot to assign the return value back to the variable.

Thanks for the help!


-----Original Message-----
From: jdev-admin at jabber.org [mailto:jdev-admin at jabber.org] On Behalf Of Joe
Sent: Monday, February 02, 2004 6:56 PM
To: 'jdev at jabber.org'
Subject: RE: [JDEV] Jabber and Flash

You probably have to set your server to expect this:

<stream:stream .../>NUL

Where the stream:stream doesn't actually wrap the stanzas.

Joe Hildebrand


> -----Original Message-----
> From: Keith Willis [mailto:kwillis at cyberlearninglabs.com]
> Sent: Monday, February 02, 2004 4:03 PM
> To: jdev at jabber.org
> Subject: [JDEV] Jabber and Flash
> All,
> I have a .NET version of the jabber server (Joey using Jabber-Net).  
> It connects to IM programs just fine, but I also would like it to 
> connect to Flash.
> I am aware of Flash requiring null terminating streams, so I adjusted 
> the server to send streams null terminated.
> This seems to start out fine, I send the initial request from Flash, 
> the server accepts it and processes it and will send a response to the 
> flash client.  The flash client then tries to do an authentication 
> request.  At this point any message coming from flash, the server will 
> drop regardless of what the message data contains.  I can still 
> connect with my other IM clients and it works fine.
> Has anyone encountered this before?  Even if it is not .NET related, I 
> would appreciate a response as to how the problem was resolved.  I may 
> be able to do something similar in the .NET server.
> Thanks,
> Keith
> _______________________________________________
> jdev mailing list
> jdev at jabber.org
> http://mailman.jabber.org/listinfo/jdev
jdev mailing list
jdev at jabber.org

More information about the JDev mailing list